Issue
When signing up to a club you may encounter the following Out of stock checkout alert.

Common Cause
This error is usually caused by two different scenarios: Either the product is not published to the Online Store Sales Channel, or there is no available stock at the default Online Store fulfilment location.
How to Resolve
Generally, the product is not out of stock and instead needs to be added to the correct sales channel. Make sure the product is published to the Online Store sales channel to resolve the issue. The publishing menu can be accessed when editing a product in Shopify.