Payment Provider Not Enabled

Payment Provider Not Enabled

Issue

During a club run you may notice that some or all orders have failed with the following error;
Payment provider is not enabled on the shop

Common Cause

Generally this occurs when a payment method has been deactivated since the customer signed up as a member. For example, if Shop Pay was active when the customer joined as a member, then this would be listed as their default payment method. If you then deactivated this payment method, this would cause any membership orders attached to that payment method to fail and display this message.

How to Resolve

The only remedy for this error is to reinstate the missing payment method via Shopify. Or, you will need to seek alternative payment details for the customer and re-enter these. See Payment Methods for more details.

Info
If the failed billing attempts are from migrated contracts, ensure Stripe is enabled as a secondary gateway. You should see the following in your Shopify payments menu.

    • Related Articles

    • Payment Methods

      Changing Club Payment Methods Customer Portal The customer can update their club payment method by logging into the customer portal on your website and clicking 'Payment Methods'. Shopify Admin In Shopify admin, open the Shopify customer record. In ...
    • No Inventory Location Found or Enabled

      Issue During a club run or rebilling a subscription, you may encounter advising No inventory location found or enabled. Common Cause The two main causes of this issue are: One or more of the products involved in the shipment does not have the correct ...
    • Failed Payments

      Winehub provides robust automation to help manage failed payment attempts for subscription orders, reducing manual follow-ups and improving club order success rates. VIDEO GUIDE: Billing Behaviour & Failed Payments Failed payments are only followed ...
    • Migration Overview

      We understand that transitioning to a new platform can feel overwhelming. That's why we offer an optional migration service to help you bring your existing members across from another platform. This is a bookable service designed to make the ...
    • Third Party Integrations

      Winehub integrates with a range of trusted third-party platforms to extend the functionality of your store. These integrations support payments, compliance, inventory management, fulfilment, reservations and marketing, allowing you to connect Winehub ...